Cisco ASA 5505 Memory Upgrade

Hi Folks! So I was trying to update my Cisco ASA 5505 my buddy gave me from version 8.2 to 9.1. However upon reloading the device with the new 9.1 image file I got a warning on the console! I received the error of purchase Cisco item “ASA5505-MEM-512=”



After some research I found that my ASA 5505 was an older one that only had 256MB of RAM, and according to Cisco’s site any version of the ASA 8.3+ requires 512MB!! So what to do, what to do? After googling around I discovered the make and form factor of the RAM inside Cisco ASA 5505’s. They use PC3200 or DDR400. Newer ones are shipped with 512MB, while the older Cisco 5505 are shipped with 256MB.

I purchased a 1GB module from amazon, located here. I removed the 4 screws on the underbody and slid off the cover. It is very easy to identify the compact flash card and the RAM module. Removed the RAM module and replaced it with the 1GB module.

Upon reload, I issued a:

You could also do a show version:

As we can see the 1GB module is working!! Now to upload and boot from the 9.1 image.
Copy over your 9.1 image however you see fit, for me I used PumpKIN and tftp’d it over. And don’t forget to designate it as the boot image.

Do a reload and verify the new version is the one being used.

***Here are some pictures on how to remove and locate the RAM module.(these are from source *1):

Sources:

Leave a Reply